category / Ruby

Ruby

【Ruby】予期しないエラーが発生した場合、例外処理をする

Ruby で、予期しないエラーが発生した場合、メッセージを表示するように、例外処理します。 今回は、数値を文字列で割ったため、エラーが発生するようにします。 まずは、 begin…

続きを読む
2022年08月02日1 分
Ruby

【Ruby】クラス内のメソッドを外部で読み込まないようにする

Ruby でクラス内のメソッドを外部から読み込まれないようにするには private を使用します。 読み込まれたくないメソッドの上の行に private を入力しましょう。 ターミナルで実行すると、 fluit…

続きを読む
2022年08月01日1 分
Ruby

【Ruby】moduleを作成する

Ruby で module を作成します。 module は、class のように継承ができなく、インスタンスも作ることができません。 Fluit の module を作成します。 module と入力し、module 名を入力します。 インデントし、 def…

続きを読む
2022年07月31日1 分
Ruby

【Ruby】親クラスの内容を小クラスに引き継ぐ

Ruby で、親クラスの内容を小クラスに引き継ぐことを、クラスの継承といいます。 例えば、以下の親クラスがあるとします。 Parfait という子クラスを作成し、Fluit クラスを継承します。 方法は、子クラスに『<』を入力し、親クラスを入力します。 Parfait…

続きを読む
2022年07月30日1 分
Ruby

【Ruby】インスタンス毎に値を共有できるクラス変数を作成する

Ruby で、インスタンス毎に値を共有できる、クラス変数を作成します。 今回は、インスタンスが作成される度、値が 1 ずつ増えるクラス変数を作成します。 クラス変数を作成するには、変数名の前に『@@』を付けます。 initialize の中に、 @@fluit_number…

続きを読む
2022年07月29日1 分
Ruby

【Ruby】クラスのinitializeメソッドで作成したインスタンスを、外部で読み書きする

クラスの initialize メソッドで作成したインスタンスを、外部で読み込みます。 上のコードでも読み取ることができるのですが、 attr_reader を使用すると、より簡単に記述することができます。 インスタンスを外部で読み込む initialize…

続きを読む
2022年07月28日2 分
Ruby

【Ruby】クラスのinitializeメソッドで値を保持する

クラスの initialize メソッドを使い、値を保持します。 クラス内で、 def を入力し、 initialize() を入力します。 initialize…

続きを読む
2022年07月27日1 分
Ruby

【Ruby】クラスを作成する

Rubyでクラスを作成します。 Fluitクラスの中で、fluitというメソッドを呼び出すようにします。 まずは、 class と入力し、クラス名を入力します。 インデントし、 def と入力し、メソッド名を入力します。 実行したい内容を入力し、 end…

続きを読む
2022年07月26日1 分
Ruby

【Ruby】timesを使い、指定した回数分、繰り返し処理する

Ruby の times を使い、指定した回数分、繰り返し処理をします。 今回は、fluits の配列を順番に 3 つ取り出します。 数字を入力し、『.times』と入力します。 今回は、3 を入力します。 『{}』で閉じます。 『{}』の中に、『|i…

続きを読む
2022年07月25日1 分
Ruby

【Ruby】downtoを使って、指定の範囲内で1ずつ減らしながら繰り返し処理する

Ruby で downto を使って、4 から 2 まで 1 ずつ減らしながら繰り返し処理します。 今回は、フルーツの配列を一つずつ取り出します。 まずは、初期値である 4 を入力し、『.downto()』を入力します。 『.downto…

続きを読む
2022年07月24日1 分
Ruby

【Ruby】uptoを使って、指定の範囲内で1ずつ増やしながら繰り返し処理する

Ruby で upto を使って、0 から 2 まで 1 ずつ増やしながら繰り返し処理します。 今回は、フルーツの配列を一つずつ取り出します。 まずは、初期値である 0 を入力し、『.upto()』を入力します。 『.upto…

続きを読む
2022年07月24日1 分
Ruby

【Ruby】whileを使い、繰り返し処理する

Ruby で while を使って、特定の条件まで繰り返し処理します。 今回は、フルーツの配列から 3 つ取り出すまで繰り返します。 配列と i=0 を設定します。 while を設定し、i が 3 未満まで実行します。 インデントし、実行内容を入力します。 fluits…

続きを読む
2022年07月23日1 分
Ruby

【Ruby】eachを使ってハッシュを一つずつ取り出す

Rubyで each を使って、ハッシュを一つずつ取り出します。 まずは、ハッシュを設定します。 ハッシュ名の後に『.each do』を入力します。 『|k, v|』と入力します。 kはキー、vは値を指しています。 kとvは、keyやvalue…

続きを読む
2022年07月22日1 分
Ruby

【Ruby】eachを使って配列を一つずつ取り出す

Ruby で each を使って、配列を一つずつ取り出します。 配列名の後に『.each do |変数の名前|』を入力します。 インデントし、実行したい内容を入力します。 end…

続きを読む
2022年07月21日1 分
Ruby

【Ruby】ハッシュを設定する

ハッシュとは、キーと値の組み合わせでできているデータのことをいいます。 設定方法は、『{}』の中に、キーを入力し、『=>』入力後、値を入力します。 キーをもとに値を取り出すには、変数名の後に『[]』を入力し、『[]』の中で指定します。 ターミナルで実行すると、 orange…

続きを読む
2022年07月20日1 分
Ruby

【Ruby】連番の配列を簡単に作成する

0から6の連番を作成しました。 Rubyで連番の配列を作成する場合、 .to_a を使うと、簡単に作成することができます。 『()』を入力し、()の中に、初めの数値と終わりの数値の間に『..』を入力します。 今回は、0から6までの連番を作成したいので、『(0..…

続きを読む
2022年07月19日1 分
Ruby

【Ruby】配列にデータを追加する

Rubyで、以下の配列にデータを追加します。 pushを使う push を使って、配列を追加します。 numbersの後に『.push()』と入力します。 『()』の中に、追加したいデータを入力します。 ターミナルで実行すると、 配列の最後に7…

続きを読む
2022年07月19日1 分
Ruby

【Ruby】メソッドを使う

Rubyでメソッドを使います。 メソッドとは、複数の処理を一つにまとめた処理内容のことをいいます。 JavaScriptでは、関数を指します。 まずは、 def を入力し、後にメソッド名を入力します。 インデントし、実行したい内容を入力します。 end…

続きを読む
2022年07月18日1 分
Ruby

【Ruby】unlessで条件分岐する方法

Aが正しくない限り×、正しければ◯といった条件分岐を、unlessを使いRubyで作成します。 条件分岐の内容は、numberが60以上でない限り『まあまあ』、60以上であるとは『良い』とします。 numberを63で進めます。 まずは、 unless…

続きを読む
2022年07月17日1 分
Ruby

【Ruby】whenで条件分岐する方法

条件がAの時は◯、Bの時は△、それ以外は□といった条件分岐を、whenを使いRubyで作成します。 条件分岐の内容は、tempが晴れの場合『傘を持っていく必要ない』、曇りの場合『傘を持っていった方がいいかも』、それ以外『傘を持っていく必要がある』とします。 temp…

続きを読む
2022年07月17日1 分
Ruby

【Ruby】ifで条件分岐する方法

もしAが正しければ◯、正しくなければ×といった条件分岐を、ifを使いRubyで作成します。 条件分岐の内容は、numberが80以上は『良い』、60以上は『まあまあ良い』、60未満は『まあまあ』とします。 numberを63で進めます。 まずは、 if と入力し、…

続きを読む
2022年07月16日1 分
Ruby

【Ruby】文字列を数値に、数値を文字列に変換する

Ruby の演算子で、文字列と数値を同時に使うと、 数値から文字列へ暗黙の変換は行いません、というエラーが発生します。 演算子を使う場合、数値を文字列を揃える必要があります。 数値を文字列に変換する 数値を文字列に変えるには、変数名の後に『.to_s…

続きを読む
2022年07月15日1 分
Ruby

【Ruby】文字列を改行する

Rubyで文字列を改行します。 改行したい文字列を『””』で囲みます。 改行したい場所に『 \ n』を入力します。 Rubyで実行し、ターミナルで確認すると、 『 \ n』を入力した場所で改行されました。 ちなみに、文字列を『””』ではなく、『’’』で囲むと、 『\n…

続きを読む
2022年07月14日1 分
Ruby

【Ruby】文字列の中に、ローカル変数を代入する

文字列の中に、ローカル変数を代入します。 まずは、表示したい文字列を『””』で囲みます。 次に、ローカル変数を表示したい場所に『#{}』を入力します。 『#{}』の中にローカル変数を入力します。 Ruby…

続きを読む
2022年07月14日1 分
Ruby

【Ruby】ローカル変数を実行する

Rubyでローカル変数を使います。 Rubyでは、変数の前にvarなどの修飾子を使用しません。 例えば、2+2の式の変数では、以下のコードになります。 実行してみると、 2+2の結果である…

続きを読む
2022年07月13日1 分
Ruby

【Ruby】IRBを使い、Rubyを実行する

IRB を使い、対話形式で Ruby を実行できるようになります。 まずは、IRB をインストールします。 ターミナルで gem install irb を実行します。 インストール完了後、ターミナルで irb を実行すると、 IRB が起動しました。 試しに、Hello…

続きを読む
2022年07月12日1 分